using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\n(http(s)?:.*)";
string substitution = @"<a href=""$2"">$1</a>";
string input = @"link1
http://linkdemo1.com/path/
link2
http://linkdemo2.com/path/
link3
http://linkdemo3.com/path/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}