// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)\n(http(s)?:.*)").unwrap();
let string = "link1
http://linkdemo1.com/path/
link2
http://linkdemo2.com/path/
link3
http://linkdemo3.com/path/";
let substitution = "<a href=\"$2\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}