import re
regex = re.compile(r"(\w+)\n(http(s)?:.*)")
test_str = ("link1\n"
"http://linkdemo1.com/path/\n\n"
"link2\n"
"http://linkdemo2.com/path/\n\n"
"link3\n"
"http://linkdemo3.com/path/")
subst = "<a href=\"$2\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)