re = /(\w+)\n(http(s)?:.*)/
str = 'link1
http://linkdemo1.com/path/
link2
http://linkdemo2.com/path/
link3
http://linkdemo3.com/path/'
subst = '<a href="$2">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result