$re = '/(\w+)\n(http(s)?:.*)/';
$str = 'link1
http://linkdemo1.com/path/
link2
http://linkdemo2.com/path/
link3
http://linkdemo3.com/path/';
$subst = "<a href=\"$2\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;