using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\]]*)\]|(\S+)";
string substitution = @"$1$2";
string input = @"CODE FIRSTTYPE: [DATA OF FIRST TYPE] SECONDTYPE: [DATA OF SECOND TYPE]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}