re = /\[([^\]]*)\]|(\S+)/
str = 'CODE FIRSTTYPE: [DATA OF FIRST TYPE] SECONDTYPE: [DATA OF SECOND TYPE]'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result