import Foundation
let pattern = #"\[([^\]]*)\]|(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"CODE FIRSTTYPE: [DATA OF FIRST TYPE] SECONDTYPE: [DATA OF SECOND TYPE]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)