const regex = /\[([^\]]*)\]|(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\]]*)\\]|(\\S+)', 'g')
const str = `CODE FIRSTTYPE: [DATA OF FIRST TYPE] SECONDTYPE: [DATA OF SECOND TYPE]`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);