# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Group Policyholder: ((?:.)*)/$1/;t' <<< "Group Policyholder: Goldman, Sachs & Co."