import re
regex = re.compile(r"Group Policyholder: ((?:.)*)")
test_str = "Group Policyholder: Goldman, Sachs & Co."
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)