package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U).*= (.*)<BR>.*= (.*)<BR>.*= (.*)<BR>.*= (.*)`)
var str = []byte(`Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = `)
var substitution = []byte("NAME - $1\nFEATUREID - $2\nDesc - $3\nKultura - $4")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}