# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*= (.*)<BR>.*= (.*)<BR>.*= (.*)<BR>.*= (.*)"
test_str = "Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = "
subst = "NAME - $1\\nFEATUREID - $2\\nDesc - $3\\nKultura - $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.