use strict;
my $str = 'Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = ';
my $regex = qr/.*= (.*)<BR>.*= (.*)<BR>.*= (.*)<BR>.*= (.*)/p;
my $subst = 'NAME - $1\\nFEATUREID - $2\\nDesc - $3\\nKultura - $4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";