#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "DB2(?<version>\s\d+\.\d+)"
Local $sString = "DB2 9.7.10.1 " & @CRLF & _
"DB2 10.1.4.4 " & @CRLF & _
"DB2 9.7.600.413 " & @CRLF & _
"DB2 9.7.9.8 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")