using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"DB2(?<version>\s\d+\.\d+)";
string input = @"DB2 9.7.10.1
DB2 10.1.4.4
DB2 9.7.600.413
DB2 9.7.9.8 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}