package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`DB2(?<version>\s\d+\.\d+)`)
var str = `DB2 9.7.10.1
DB2 10.1.4.4
DB2 9.7.600.413
DB2 9.7.9.8 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}