re = /DB2(?<version>\s\d+\.\d+)/
str = 'DB2 9.7.10.1
DB2 10.1.4.4
DB2 9.7.600.413
DB2 9.7.9.8 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end