import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "DB2(?<version>\\s\\d+\\.\\d+)";
final String string = "DB2 9.7.10.1 \n"
+ "DB2 10.1.4.4 \n"
+ "DB2 9.7.600.413 \n"
+ "DB2 9.7.9.8 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}