using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((0[1-9]|[1-2]\d|3[0-1])\/(0[13578]|1[02]))|((0[1-9]|[1-2]\d|30)\/(0[46]|11))|((0[1-9]|1[\d]|2[0-8])\/02))\/(19|20)\d{2}$";
string input = @"31/12/2099
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}