use strict;
my $str = '31/12/2099
';
my $regex = qr/^(((0[1-9]|[1-2]\d|3[0-1])\/(0[13578]|1[02]))|((0[1-9]|[1-2]\d|30)\/(0[46]|11))|((0[1-9]|1[\d]|2[0-8])\/02))\/(19|20)\d{2}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}