package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((0[1-9]|[1-2]\d|3[0-1])\/(0[13578]|1[02]))|((0[1-9]|[1-2]\d|30)\/(0[46]|11))|((0[1-9]|1[\d]|2[0-8])\/02))\/(19|20)\d{2}$`)
var str = `31/12/2099
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}