const regex = /^(((0[1-9]|[1-2]\d|3[0-1])\/(0[13578]|1[02]))|((0[1-9]|[1-2]\d|30)\/(0[46]|11))|((0[1-9]|1[\d]|2[0-8])\/02))\/(19|20)\d{2}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((0[1-9]|[1-2]\\d|3[0-1])\\\/(0[13578]|1[02]))|((0[1-9]|[1-2]\\d|30)\\\/(0[46]|11))|((0[1-9]|1[\\d]|2[0-8])\\\/02))\\\/(19|20)\\d{2}$', 'g')
const str = `31/12/2099
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}