import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((0[1-9]|[1-2]\\d|3[0-1])\\/(0[13578]|1[02]))|((0[1-9]|[1-2]\\d|30)\\/(0[46]|11))|((0[1-9]|1[\\d]|2[0-8])\\/02))\\/(19|20)\\d{2}$";
final String string = "31/12/2099\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}