import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?:.*?(abc)|.*?(a.c)|.*?(def)|.*?(%#@)|.*?(1z;))";
final String string = "1z;%#@defarcabcaqcdef%#@1z;\n"
+ "1z;%#@defarcabaqcdef%#@1z;\n"
+ "1z;%#@defacabacdef%#@1z;\n"
+ "1z;%#@deacabacdf%#@1z;\n"
+ "foo;%@deaabade#@1z;barbbbaarr3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}