import re
regex = re.compile(r"(?m)^(?:.*?(abc)|.*?(a.c)|.*?(def)|.*?(%#@)|.*?(1z;))")
test_str = ("1z;%#@defarcabcaqcdef%#@1z;\n"
"1z;%#@defarcabaqcdef%#@1z;\n"
"1z;%#@defacabacdef%#@1z;\n"
"1z;%#@deacabacdf%#@1z;\n"
"foo;%@deaabade#@1z;barbbbaarr3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")