re = /(?m)^(?:.*?(abc)|.*?(a.c)|.*?(def)|.*?(%#@)|.*?(1z;))/
str = '1z;%#@defarcabcaqcdef%#@1z;
1z;%#@defarcabaqcdef%#@1z;
1z;%#@defacabacdef%#@1z;
1z;%#@deacabacdf%#@1z;
foo;%@deaabade#@1z;barbbbaarr3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end