// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?(abc)|.*?(a.c)|.*?(def)|.*?(%#@)|.*?(1z;))").unwrap();
let string = "1z;%#@defarcabcaqcdef%#@1z;
1z;%#@defarcabaqcdef%#@1z;
1z;%#@defacabacdef%#@1z;
1z;%#@deacabacdf%#@1z;
foo;%@deaabade#@1z;barbbbaarr3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}