using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9a-fA-F]+\\s+[0-9a-fA-F]+\\*?\\s+\\d+\\s+\\.word\\s+(?:\\w+\\d+\\()?_(\\w+)\\)?[\\.\\w]*
";
string input = @"Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=""M"",""Mr."",""Ms."")%%%}%%%} {%LastName%}
{%%% Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=""M"",""Mr."",""Ms."")%%%}%%%} {%LastName%}
{%%%{%%%=Select(DepartmentID,1,{%%%=if(Gender=""M"",""Mr."",""Ms."")%%%}%%%} {%LastName%}
{%%%{%%%=abcd%%%}
It also matches {%%%=ab{%%%=abcd%%%}cd%%%} either.
This {%%%{%%%=ab{%%%=abcd%%%}cd%%%}%%%}%%%}
{%%%{%%%=1234{%%%=match_this_shit_bitches%%%}%%%}%%%}
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}