use strict;
my $str = 'Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%% Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%%{%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%%{%%%=abcd%%%}
It also matches {%%%=ab{%%%=abcd%%%}cd%%%} either.
This {%%%{%%%=ab{%%%=abcd%%%}cd%%%}%%%}%%%}
{%%%{%%%=1234{%%%=match_this_shit_bitches%%%}%%%}%%%}
';
my $regex = qr/[0-9a-fA-F]+\\s+[0-9a-fA-F]+\\*?\\s+\\d+\\s+\\.word\\s+(?:\\w+\\d+\\()?_(\\w+)\\)?[\\.\\w]*
/mixsup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}