$re = '/[0-9a-fA-F]+\\\\s+[0-9a-fA-F]+\\\\*?\\\\s+\\\\d+\\\\s+\\\\.word\\\\s+(?:\\\\w+\\\\d+\\\\()?_(\\\\w+)\\\\)?[\\\\.\\\\w]*
/mixXsuUAJD';
$str = 'Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%% Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%%{%%%=Select(DepartmentID,1,{%%%=if(Gender="M","Mr.","Ms.")%%%}%%%} {%LastName%}
{%%%{%%%=abcd%%%}
It also matches {%%%=ab{%%%=abcd%%%}cd%%%} either.
This {%%%{%%%=ab{%%%=abcd%%%}cd%%%}%%%}%%%}
{%%%{%%%=1234{%%%=match_this_shit_bitches%%%}%%%}%%%}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);