# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[0-9a-fA-F]+\\s+[0-9a-fA-F]+\\*?\\s+\\d+\\s+\\.word\\s+(?:\\w+\\d+\\()?_(\\w+)\\)?[\\.\\w]*
"""
test_str = ("Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}\n"
"{%%% Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}\n"
"{%%%{%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}\n"
"{%%%{%%%=abcd%%%} \n"
"It also matches {%%%=ab{%%%=abcd%%%}cd%%%} either.\n"
"This {%%%{%%%=ab{%%%=abcd%%%}cd%%%}%%%}%%%}\n"
"{%%%{%%%=1234{%%%=match_this_shit_bitches%%%}%%%}%%%}\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE | re.DOTALL | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.