// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mixsuU)[0-9a-fA-F]+\\s+[0-9a-fA-F]+\\*?\\s+\\d+\\s+\\.word\\s+(?:\\w+\\d+\\()?_(\\w+)\\)?[\\.\\w]*
").unwrap();
let string = "Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}
{%%% Hello {%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}
{%%%{%%%=Select(DepartmentID,1,{%%%=if(Gender=\"M\",\"Mr.\",\"Ms.\")%%%}%%%} {%LastName%}
{%%%{%%%=abcd%%%}
It also matches {%%%=ab{%%%=abcd%%%}cd%%%} either.
This {%%%{%%%=ab{%%%=abcd%%%}cd%%%}%%%}%%%}
{%%%{%%%=1234{%%%=match_this_shit_bitches%%%}%%%}%%%}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}