#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http|https):\/\/[\w_-]+(?:(?:\.[\w_-]+)+)\/url\/action(?!\/\w)[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-]*"
Local $sString = "http://abc.com/url/action" -- should match. " & @CRLF & _
" http://abc.com/url/action/" -- should match." & @CRLF & _
" https://abc.com/url/action?t=true" -- should match " & @CRLF & _
" http://abc.com/url/action/?t=true" -- should match " & @CRLF & _
"" & @CRLF & _
" http://abc.com/url/action/test" -- should NOT match" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")