const regex = /(http|https):\/\/[\w_-]+(?:(?:\.[\w_-]+)+)\/url\/action(?!\/\w)[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https):\\\/\\\/[\\w_-]+(?:(?:\\.[\\w_-]+)+)\\\/url\\\/action(?!\\\/\\w)[\\w.,@?^=%&:\\\/~+#-]*[\\w@?^=%&\\\/~+#-]*', 'g')
const str = `http://abc.com/url/action" -- should match.
http://abc.com/url/action/" -- should match.
https://abc.com/url/action?t=true" -- should match
http://abc.com/url/action/?t=true" -- should match
http://abc.com/url/action/test" -- should NOT match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}