import Foundation
let pattern = ##"(http|https):\/\/[\w_-]+(?:(?:\.[\w_-]+)+)\/url\/action(?!\/\w)[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-]*"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://abc.com/url/action" -- should match.
http://abc.com/url/action/" -- should match.
https://abc.com/url/action?t=true" -- should match
http://abc.com/url/action/?t=true" -- should match
http://abc.com/url/action/test" -- should NOT match
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)