using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/[\w_-]+(?:(?:\.[\w_-]+)+)\/url\/action(?!\/\w)[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-]*";
string input = @"http://abc.com/url/action"" -- should match.
http://abc.com/url/action/"" -- should match.
https://abc.com/url/action?t=true"" -- should match
http://abc.com/url/action/?t=true"" -- should match
http://abc.com/url/action/test"" -- should NOT match
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}