$re = '/(http|https):\/\/[\w_-]+(?:(?:\.[\w_-]+)+)\/url\/action(?!\/\w)[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-]*/';
$str = 'http://abc.com/url/action" -- should match.
http://abc.com/url/action/" -- should match.
https://abc.com/url/action?t=true" -- should match
http://abc.com/url/action/?t=true" -- should match
http://abc.com/url/action/test" -- should NOT match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);