using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""(\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\d|0?[1-9]))""\^\^xsd:date$";
string input = @"""1999-02-5""^^xsd:date
""1999-12-08""^^xsd:date
""1999-08-16""^^xsd:date
""1999-12-31""^^xsd:date";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}