// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"(\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\d|0?[1-9]))"\^\^xsd:date$"#).unwrap();
let string = "\"1999-02-5\"^^xsd:date
\"1999-12-08\"^^xsd:date
\"1999-08-16\"^^xsd:date
\"1999-12-31\"^^xsd:date";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}