package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"(\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\d|0?[1-9]))"\^\^xsd:date$`)
var str = `"1999-02-5"^^xsd:date
"1999-12-08"^^xsd:date
"1999-08-16"^^xsd:date
"1999-12-31"^^xsd:date`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}