$re = '/^"(\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\d|0?[1-9]))"\^\^xsd:date$/m';
$str = '"1999-02-5"^^xsd:date
"1999-12-08"^^xsd:date
"1999-08-16"^^xsd:date
"1999-12-31"^^xsd:date';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);