const regex = /^"(\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\d|0?[1-9]))"\^\^xsd:date$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"(\\d{4}-(?:0?[1-9]|1[012])-(?:30|31|[12]\\d|0?[1-9]))"\\^\\^xsd:date$', 'gm')
const str = `"1999-02-5"^^xsd:date
"1999-12-08"^^xsd:date
"1999-08-16"^^xsd:date
"1999-12-31"^^xsd:date`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}