using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*(?:\""([^\""]*)\""|([^,]+))\s*,?)+?";
string input = @"dgsfdgsdg dfgdsfg ""30"",2014-08-08,""100"",""MT"",""8"",""3624"",""#"",""#"",1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}