re = /(?:\s*(?:\"([^\"]*)\"|([^,]+))\s*,?)+?/
str = 'dgsfdgsdg dfgdsfg "30",2014-08-08,"100","MT","8","3624","#","#",1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end