const regex = /(?:\s*(?:\"([^\"]*)\"|([^,]+))\s*,?)+?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(?:\\"([^\\"]*)\\"|([^,]+))\\s*,?)+?', 'g')
const str = `dgsfdgsdg dfgdsfg "30",2014-08-08,"100","MT","8","3624","#","#",1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}