$re = '/(?:\s*(?:\"([^\"]*)\"|([^,]+))\s*,?)+?/';
$str = 'dgsfdgsdg dfgdsfg "30",2014-08-08,"100","MT","8","3624","#","#",1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);