import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ "(\\/\\/[ \\t]*)\n"
+ "(\n"
+ "\\[(?:\n"
+ " (?:[-]?\\d+(?:.\\d)*)(?:[ \\t]*:[ \\t]*-?\\d+(?:.\\d)*){0,2} \n"
+ " |\n"
+ " (?:(?:[^:,]+:)?[^:,]+,)*(?:(?:[^:,]+:)?[^:,]+)\n"
+ ")\\]\n"
+ ")\n"
+ "[ \\t]*$\\n?";
final String string = "\n"
+ "// Internal Diameter\n"
+ "innerWidth = 11.733333; // [40]\n"
+ "innerWidth = 11.733333; \n"
+ "// \n"
+ "[Invalid: thing]\n"
+ "height = 14;\n"
+ "wallWidth = 2;\n\n"
+ "//#region [Options] Advanced\n\n"
+ "/* [Advanced Options] */\n"
+ "enable_sloped_walls =true; // [10:20]\n"
+ "outerWidth_delta = 0.2;\n\n"
+ "enable_sloped_walls_inner = true;\n"
+ "innerDelta = -1;\n\n"
+ "rounded_top = true;\n"
+ "rounding_top = nothing * 5;\n\n"
+ "rounded_bottom = false;\n"
+ "rounding_bottom = 1.5;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}