use strict;
my $str = '
// Internal Diameter
innerWidth = 11.733333; // [40]
innerWidth = 11.733333;
//
[Invalid: thing]
height = 14;
wallWidth = 2;
//#region [Options] Advanced
/* [Advanced Options] */
enable_sloped_walls =true; // [10:20]
outerWidth_delta = 0.2;
enable_sloped_walls_inner = true;
innerDelta = -1;
rounded_top = true;
rounding_top = nothing * 5;
rounded_bottom = false;
rounding_bottom = 1.5;';
my $regex = qr/(?x)
(\/\/[ \t]*)
(
\[(?:
(?:[-]?\d+(?:.\d)*)(?:[ \t]*:[ \t]*-?\d+(?:.\d)*){0,2}
|
(?:(?:[^:,]+:)?[^:,]+,)*(?:(?:[^:,]+:)?[^:,]+)
)\]
)
[ \t]*$\n?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";