// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?x)
(\/\/[ \t]*)
(
\[(?:
(?:[-]?\d+(?:.\d)*)(?:[ \t]*:[ \t]*-?\d+(?:.\d)*){0,2}
|
(?:(?:[^:,]+:)?[^:,]+,)*(?:(?:[^:,]+:)?[^:,]+)
)\]
)
[ \t]*$\n?").unwrap();
let string = "
// Internal Diameter
innerWidth = 11.733333; // [40]
innerWidth = 11.733333;
//
[Invalid: thing]
height = 14;
wallWidth = 2;
//#region [Options] Advanced
/* [Advanced Options] */
enable_sloped_walls =true; // [10:20]
outerWidth_delta = 0.2;
enable_sloped_walls_inner = true;
innerDelta = -1;
rounded_top = true;
rounding_top = nothing * 5;
rounded_bottom = false;
rounding_bottom = 1.5;";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}